3dvdm and VR++ on ubuntu

Prerequisites

To compile the tools you need those packages:

  • lam4-dev
  • libtiff-dev
  • freeglut3-dev
  • libgtk2.0-dev
  • libgtk1.2-dev
  • libcairo2-dev
  • libxmu-dev
  • lam-runtime
  • libgsl0-dev

Modification of the Makefiles

To allow vr++ to correctly link the cairo.h file you have to edit two Makefiles:

  • vr++/gtk/tasks/Makefile
  • vr++/gtk/slaves/Makefile

and modify the INC line

INC             = -I/usr/include/cairo/ -I../include -I$(BUILD_DIR)/include $(GTK_INC)

Now you can proceed to compile vr++ and 3dvdm as usual

/var/www/wiki.inf.unibz.it/data/pages/public/3dvdm_on_ubuntu.txt · Last modified: 2019/01/16 10:03 (external edit)
CC Attribution-Share Alike 4.0 International
Driven by DokuWiki Recent changes RSS feed Valid CSS Valid XHTML 1.0